27/03/2023

C++ Class Template Specialization Hackerrank Solution in C++

C++ Class Template Specialization Hackerrank Solution in C++. You are given a main function which reads the enumeration values for two different types as input and then prints out the corresponding enumeration names. Write a class template that can provide the names of the enumeration values for both types. If the enumeration value is not valid, then print unknown.

Input Format

The first line contains t, the number of test cases.
Each of the t subsequent lines contains two space-separated integers. The first integer is a colour value, c, and the second integer is a fruit value, f.

Output Format

The locked stub code in your editor prints t lines containing the colour name and the fruit name corresponding to the input enumeration index.

C++ Class Template Specialization Hackerrank Solution in C++

Sample Input

2
1 0
3 3

Sample Output

green apple
unknown unknown

Explanation

Since t = 2, there are two lines of output.

The two input index values, 1 and 0, correspond to green in the colour enumeration and apple in the fruit enumeration. Thus, we print green apples.
The two input values, 3 and 3, are outside of the range of our enums. Thus, we print unknown.

Submit your solution here: Click here

C++ Class Template Specialization Hackerrank Solution in C++


#include <iostream>
using namespace std;
enum class Fruit
{
	apple, orange, pear
};

enum class Color
{
	red, green, orange
};

template < typename T > struct Traits;

// Define specializations for the Traits class template here.
template < >
	struct Traits < Fruit>
	{
		public: static
		const char *name(int index)
		{
			Fruit f = (Fruit) index;
			switch (f)
			{
				case Fruit::apple:
					return "apple";
				case Fruit::orange:
					return "orange";
				case Fruit::pear:
					return "pear";
			}

			return "unknown";
		}
	};

template < >
	struct Traits < Color>
	{
		public: static
		const char *name(int index)
		{
			Color c = (Color) index;
			switch (c)
			{
				case Color::red:
					return "red";
				case Color::green:
					return "green";
				case Color::orange:
					return "orange";
			}

			return "unknown";
		}
	};

int main()
{
	int t = 0;
	std::cin >> t;

	for (int i = 0; i != t; ++i)
	{
		int index1;
		std::cin >> index1;
		int index2;
		std::cin >> index2;
		cout <<Traits<Color>::name(index1) << " ";
		cout <<Traits<Fruit>::name(index2) << "\n";
	}
}

The Output of C++ Class Template Specialization Solution


The Output of C++ Class Template Specialization Solution

Similar to C++ Class Template Specialization


Previous Post
Next Post

post written by:

Hi, I’m Ghanendra Yadav, SEO Expert, Professional Blogger, Programmer, and UI Developer. Get a Solution of More Than 500+ Programming Problems, and Practice All Programs in C, C++, and Java Languages. Get a Competitive Website Solution also Ie. Hackerrank Solutions and Geeksforgeeks Solutions. If You Are Interested to Learn a C Programming Language and You Don't Have Experience in Any Programming, You Should Start with a C Programming Language, Read: List of Format Specifiers in C.
Follow Me

0 Comments: