24/03/2023

Vector Sort Hackerrank Solution in C++ | Hackerrank Solution

Vector Sort Hackerrank Solution in C++. You are given N integers. Sort the N integers and print the sorted order. Store the N integers in a vector. Vectors are sequence containers representing arrays that can change in size.

Vector Sort Hackerrank Solution in C++

Declaration:

vector<int>v; (creates an empty vector of integers)

Size:

int size=v.size();

Pushing an integer into a vector:

v.push_back(x);(where x is an integer.The size increases by 1 after this.)

Popping the last element from the vector:

v.pop_back(); (After this the size decreases by 1)

Sorting a vector:

sort(v.begin(),v.end()); (Will sort all the elements in the vector)

To know more about vectors, Click Here

Input Format

The first line of the input contains N where N is the number of integers. The next line contains N integers.

Constraints

1 <= N <= 10^5
1 <= Vi <= 10^9, where Vi is the ith integer in the vector.

Output Format

Print the integers in the sorted order one by one in a single line followed by a space.

Sample Input

5
1 6 10 8 4

Sample Output

1 4 6 8 10

Submit your solution here: Click here

Vector Sort Hackerrank Solution in C++


#include <cmath>
#include <cstdio>
#include <vector>
#include <iostream>
#include <algorithm>
using namespace std;

int main()
{
	int n, i;
	cin >> n;
	vector<int> arr(n);
	for (i = 0; i < n; i++)
		cin >> arr[i];
	sort(arr.begin(), arr.end());
	for (i = 0; i < n; i++)
		cout << arr[i] << " ";

	return 0;
}

The Output of Vector Sort Hackerrank Solution


The Output of Vector Sort Hackerrank Solution

Similar to Vector Sort


Previous Post
Next Post

post written by:

Hi, I’m Ghanendra Yadav, SEO Expert, Professional Blogger, Programmer, and UI Developer. Get a Solution of More Than 500+ Programming Problems, and Practice All Programs in C, C++, and Java Languages. Get a Competitive Website Solution also Ie. Hackerrank Solutions and Geeksforgeeks Solutions. If You Are Interested to Learn a C Programming Language and You Don't Have Experience in Any Programming, You Should Start with a C Programming Language, Read: List of Format Specifiers in C.
Follow Me

0 Comments: