07/03/2023

Arrays Introduction Hackerrank Solution in C++ | Hackerrank

Arrays Introduction Hackerrank Solution in C++  Language. An array is a series of elements of the same type placed in contiguous memory locations that can be individually referenced by adding an index to a unique identifier. Arrays hackerrank solution. hackerrank c++ solutions.

Arrays Introduction Hackerrank Solution in C++

For arrays of a known size, 10 in this case, use the following declaration:

int arr[10]; //Declares an array named arr of size 10, i.e, you can store 10 integers.

Note Unlike C, C++ allows dynamic allocation of arrays at runtime without special calls like malloc(). If n = 10, int arr[n] will create an array with space for 10 integers.

Accessing elements of an array:

Indexing in arrays starts from 0. So the first element is stored at arr[0], the second element at arr[1] and so on through arr[9].

You will be given an array of N integers and you have to print the integers in the reverse order.

Input Format

The first line of the input contains N, where N is the number of integers. The next line contains N space-separated integers.

Constraints

1 <= N <= 1000
1 <= A[i] <= 10000, where A[i] is the ith integer in the array.

Output Format

Print the N integers of the array in the reverse order, space-separated on a single line.

Sample Input

4
1 4 3 2

Sample Output

2 3 4 1

We know that array is used to store a similar datatype and an array is used to continue memory location in this problem we have to take input from the user and print reverse output by printing the last index first until an array's first index.

Submit your solution here: Click here

Arrays Introduction Hackerrank Solution in C++ 


#include <cmath>
#include <cstdio>
#include <vector>
#include <iostream>
#include <algorithm>
using namespace std;

int main()
{
	int n;
	cin >> n;
	int array[n];

	for (int i = 0; i < n; i++)
	{
		cin >> array[i];
	}

	for (int i = n - 1; i >= 0; i--)
	{
		cin >> array[i];
		cout << array[i] << " ";
	}

	return 0;
}

Arrays Hackerrank Solution Output


Arrays Hackerrank Solution Output

The Output of Arrays Introduction


The Output of Arrays Introduction

Similar to Arrays Hackerrank Solution


Previous Post
Next Post

post written by:

Hi, I’m Ghanendra Yadav, SEO Expert, Professional Blogger, Programmer, and UI Developer. Get a Solution of More Than 500+ Programming Problems, and Practice All Programs in C, C++, and Java Languages. Get a Competitive Website Solution also Ie. Hackerrank Solutions and Geeksforgeeks Solutions. If You Are Interested to Learn a C Programming Language and You Don't Have Experience in Any Programming, You Should Start with a C Programming Language, Read: List of Format Specifiers in C.
Follow Me

0 Comments: